Skip to main content

4 posts tagged with "flayyer-io"

View All Tags

Flayyer Variables

Patricio Lopez Juri

Patricio Lopez Juri

Founder @ Flayyer.com

We are glad to announce we added the long awaited Variables UI support on the Flayyer.com dashboard.

This allows users to know what variables are required and optional in each template.

Now an UI Widget will be displayed based on the type of the variable. We support a hint, a default value and even an array of examples! ๐Ÿคฏ

demo

You can start using it by upgrading @flayyer/cli to ^1.17.0 and installing @flayyer/variables:

yarn add --dev @flayyer/cli
yarn add @flayyer/variables

Cache invalidation

Patricio Lopez Juri

Patricio Lopez Juri

Founder @ Flayyer.com

We added a new section about Cache invalidation to our docs page so you can check it out ๐Ÿ‘€

This section explains the __v parameter that usually pops up in Flayyer URLs.

This is a random value (not so random, it is just a timestamp) to trigger cache invalidation on social networks crawlers.

You can always toggle off this feature by setting to a nullish value the meta.v parameter when using our libraries.

Added Emoji support

Patricio Lopez Juri

Patricio Lopez Juri

Founder @ Flayyer.com

Previously emojis were not rendered, until now ๐Ÿš€

We just released @flayyer/cli@1.11.0 which adds an additional post-procesisng step to add Emojis via twemoji, an amazing open-source library from Twitter.

Here is an example:

https://flayyer.io/v2/flayyer/flayyer-landing-demo/main
?title=Now+with+Emojis+๐Ÿ˜ƒ

Emoji example

Are we missing a feature? Have you found a bug? Let us know via Github: github.com/flayyer/flayyer-cli.

Embrace flayyer.io/v2

Patricio Lopez Juri

Patricio Lopez Juri

Founder @ Flayyer.com

We are saying goodbye to flayyer.io/v1 in favor of flayyer.io/v2 which has:

  • Smarter caching strategies
  • Support for anti-fakenews via encrypted signatures
  • Better handling of variables.

No worries for you, the legacy version was just being used by our early-early adopters and all them have migrated to v2.